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D i g i t a l  D e s i g n  L a b o r a t o r y  H a n d o u t  # 4  

Xilinx Foundation Tips 

Learning to Love Xilinx Foundation 4.2 i in 40  E as y  S tep s  
 

Y o u  k n o w ,  o r  w i l l  s o o n  k n o w ,  h o w  t o  d e s i g n  a n d  i m p l e m e n t  d i g i t a l  c i r c u i t s  w i t h  Xilinx F oundation design sof tware.   
B ut sometimes going f rom a good design to a working b it f ile is more stressf ul than it need b e.   H ere are some steps 

y ou can take to make the process a little more pleasant.  

Essentials 

1 .  A ny  two nets on the same lev el that hav e the same name are the same logical net, ev en if  they  are not explicitly  

wired together.     T his has some important conseq uences:  

• You do not have to draw a wire to connect two symbol pins.  You can just give the same name to the nets 
connected to these pins.  Figures 1 and 2  are equivalent, but Figure 2  is easier to understand and debug. 

 

 

Figure 1  

 

Figure 2  

 

• Two nets on the same level of hierarchy that you want to be distinct will actually be connected if you give 

them the same name.  The circuit in Figure 3  will not work because both the OR2  gate and the A N D 2  gate 
drive the same net. 

 

Figure 3  

2 . O nly one schematic should be listed in the P roj ect M anager— the highest- level schematic in your project.  If 

two schematics are listed, they will be on the same level of hierarchy and Foundation will treat them as if they 

were two parts of the same schematic. 
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Figure 4  

3. By d e f a u l t ,  t h e  s i m u l a t o r  w i l l  l o a d  t h e  n e t l i s t  o f  t h e  s c h e m a t i c ( s )  i n  yo u r  P r o je c t  M a n a g e r  w i n d o w .  To  s i m u l a t e  

a  m a c r o  by i t s e l f ,  c h o o s e  Tools->Simulate Current Macro f r o m  t h e  S c h e m a t i c  E d i t o r . 

 

Figure 5  

Al t e r n a t i ve l y,  c h o o s e  File->Simulate Single Component f r o m  t h e  L o g i c  S i m u l a t o r  a n d  s e l e c t  t h e  

m a c r o  t h a t  yo u  w a n t  t o  s i m u l a t e . 

 

Figure 6  

4 . If you want to look at signals deep within the hierarchy during simulation, just string the reference names 

together, separated by slashes, in your script.  For example, if a signal X i s  inside a macro H 1 , and H 1  is inside 

macro H 3 , H 3  is inside H 5 , and H 5  is in the highest-level schematic;  then you can refer to X in a script as 

H 5 / H 3 / H 1 / X.  
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5 .  T h e  m a c r o  a n d  t h e  s c h e m a t i c  f r o m  w h i c h  t h e  m a c r o  i s  d e r i v e d  a r e  d i f f e r e n t .   A l w a y s  o p e n  t h e  m a c r o ,  e i t h e r  

w i t h  t h e  H  “ h i e r a r c h y ”  t o o l b a r  o r  w i t h  File->Open Macro.  If you open and edit the schematic instead, the 

macro will not reflect your changes.  

6 . Before you declare a macro done, you should always perform an integrity test on the current sheet.  L ook at all 

the warnings in the Project Manager window and correct them if necessary.  You should also test your entire 

design with Options->Integrity Test. 

 

Figure 7  

 

 

Figure 8  

 

M o s t  w a r n i n g s  a r e  s e r i o u s  m a t t e r s .   A  f e w  a r e  n o t .   T h e  i n t e g r i t y  t e s t  w i l l  w a r n  y o u  i f  y o u  h a v e  n o t  c o n n e c t e d  

e v e r y  o u t p u t  o f  a  s y m b o l ,  b u t  t h a t ’ s  o f t e n  n o t  a  p r o b l e m .   F o r  e x a m p l e ,  i f  y o u  n e e d  o n l y  f o u r  o f  t h e  e i g h t  

o u t p u t s  o f  a  3 - t o - 8  d e c o d e r ,  y o u  m a y  c o n n e c t  n e t s  o n l y  t o  t h e  f o u r  y o u  i n t e n d  t o  u s e  a n d  l e a v e  t h e  o t h e r s  

d i s c o n n e c t e d .   N ever leave any  inp uts  d is c onnec ted .  

T h e  w a r n i n g  “ H i e r a r c h y  c o n n e c t o r s  o n  t o p  l e v e l  s c h e m a t i c  d e t e c t e d ”  c a n  b e  i g n o r e d  o n l y  i f  y o u  a r e  a b o u t  t o  

m a k e  t h e  s c h e m a t i c  y o u  t e s t e d  i n t o  a  m a c r o .  
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7. W h a t  a r e  t h e  f u n c t i o n s  o f  t h e  c o m p o n e n t s  i n  t h e  Sp a r t a n 2 l i br a r y?   Y o u  c a n  f i n d  o u t  i n  t h e  Li br a r i e s  G u i d e ,  

(h t t p :/ / t o o l bo x .x i l i n x .c o m / d o c s a n / x i l i n x 4/ m a n u a l s .h t m ).  A link to this WWW page is in the R esources section 

of the class WWW page. 

 

Figure 9  
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8. D o  n o t  c o p y yo u r  p r o je c t  u s i n g  W i n d o w s  c o m m a n d  l i n e  o r  g r a p h i c a l  c o m m a n d s .  Ar c h i ve  t h e  p r o je c t  o r  u s e  t h e  

File->Copy Project c o m m a n d . 

 

 

Figure 1 0  

 

Useful 
 

9 .  U s e  t h e  Draw bus taps t o o l  t o  n u m b e r  a n d  d r a w  b u s  t a p s  a u t o m a t i c a l l y .   A l l  y o u  n e e d  t o  d o  i s  c l i c k  t h e  

s o u r c e  b u s ,  t h e n  c l i c k  t h e  p i n s  t o  w h i c h  e a c h  c o n s e c u t i v e  b u s  t a p  s h o u l d  b e  a t t a c h e d .   T h e  s o f t w a r e  d o e s  a l l  t h e  

d r a w i n g  a n d  l a b e l i n g  f o r  y o u .   Y o u  c a n  u s e  t h e  a r r o w  k e y s  t o  s w i t c h  a m o n g  b i t s  o f  t h e  t a p .  

 

 

Figure 1 1  
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10 . Use the Add Net or Bus Name tool in increment mode to increment net names automatically.  Enter the 

name of the net corresponding to the lowest bit and click Repeat.  Then click the nets your want to label in order 

of increasing bit number. 

 

Figure 1 2  

 

Figure 1 3  

11. Make sure that you have labeled all your bus taps.  The arrangement in Figure 14 won’t work. 

 

Figure 1 4  

12. If the schematic looks weird, refresh the display by striking the F10  key. 
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1 3 .  T h e  b u f f e r s  a n d  p a d s  ( F i g u r e  1 5 )  a r e  I / O  f o r  t h e  c h i p .   H i e r a r c h y  c o n n e c t o r s  ( F i g u r e  1 6 ) are the I/O for macros. 

 

Figure 1 5  

 

Figure 1 6  

14. R ead the report files when implementation doesn’t work (or even when it does). 

 

Figure 1 7  
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15. U s e  t h e  View->Show All References t o  s e e  t h e  n a m e s  o f  a l l  yo u r  c o m p o n e n t s .  Th i s  w i l l  m a k e  i t  e a s i e r  

t o  f i n d  c o m p o n e n t s  i n  e r r o r  a n d  w a r n i n g  r e p o r t s . 

 

Figure 1 8  

16. E ve r y n e t  h a s  a  n a m e ,  w h e t h e r  o r  n o t  yo u  e x p l i c i t l y n a m e  i t .  S e l e c t  t h e  n e t  a n d  l o o k  a t  t h e  bo t t o m  o f  t h e  s c r e e n  

t o  f i n d  o u t  i t s  n a m e .  Be t t e r  ye t ,  g i ve  i t  a  n a m e  yo u r s e l f . 

 

Figure 1 9  
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1 7 .  T h e  n a m e  o f  a  c h i p  o u t p u t  i s  s p e c i f i e d  b y  t h e  s i g n a l  b e t w e e n  t h e  O B U F  a n d  t h e  OPAD.  Likewise the name of 

each  input is between the I PAD and I BUF.  In Figure20 , F_ OUT  is the name of the signal that connects to the 
pin and the name you will find in your PAD  report file. 

 

Figure 20 

18. As s i g n  p i n  n u m be r s  t o  e ve r y O P A D  a n d  I P A D .   If  yo u  d o n ’t ,  X i l i n x  F o u n d a t i o n  w i l l  d o  i t  f o r  yo u . 

 

F i g u r e  21  

 

F i g u r e  22 
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19. Be w a r e  o f  d i s c o n n e c t e d  n e t s !   Di s c o n n e c t e d  s i n g l e  n e t s  w i l l  u s u a l l y h a ve  bl u e  d o t s ,  bu t  n o t  a l w a ys .  

Di s c o n n e c t e d  bu s e s  w i l l  n e ve r  h a ve  bl u e  d o t s  e ve n  i f  t h e y a r e  d i s c o n n e c t e d .  Mo ve  c o m p o n e n t s  a r o u n d  t o  m a k e  

sure the connected nets move with them.  The components in both Figures 23 and 24 are disconnected, although 

you can not tell this from visual inspection of Figure 24.  D isconnected nets often occur when you replace one 

macro with another.  The Replace Symbol command (right-click on the component, then choose Replace 
Symbol) is less likely to lead to disconnected nets than other methods of replacing symbols, but only if the 
symbol interface of the new macro is the same as that of the old one. 

 

Figure 2 3  

 

Figure 2 4  

20 . If Foundation complains about “no permissions or file does not exist” while archiving your project, you have to 

reboot.  It’ s a bug and we know of no other solution. � 

21. U pdate the simulator if you make a change in the schematic.  You cannot change the schematic in the middle of 

simulation.  The safest thing to do if you need to change your schematic is to close and restart the simulator. 

22. U se the vector script command to put things in the right direction.  “vector x x[3:0]” and “vector x 
x[0:3]” arrange the bits in opposite orders.  This doesn’ t change your schematic, but it does change the way 

your “assign” statements and simulator output appear. 

23. U se the clock command to simulate clocks.  “clock CLK 0 1” makes the clock signal toggle from 0  to 1 

after one simulation step, then from 1 to 0  after another simulation step, etc.;  “clock CLK2 0 0 1 1”  
w o u l d  g i v e  CLK2 t w i c e  t h e  p e r i o d  o f  CLK .  

2 4 .  S i m u l a t i n g  i n  t i m i n g  m o d e  i s  a  g o o d  i d e a  s i n c e  y o u r  c o m p o n e n t s  w i l l  h a v e  n o n z e r o  d e l a y ,  a s  t h e y  d o  i n  r e a l  l i f e .   

B u t  b e f o r e  y o u  p l a c e  a n d  r o u t e  y o u r  d e s i g n ,  t h e  d e l a y s  t h e  s i m u l a t o r  u s e s  i n  t i m i n g  m o d e  w i l l  o n l y  b e  w i l d  

g u e s s e s .  

2 5 .  D o n ’ t  c o n f u s e  y o u r  p r o j e c t s  w i t h  t h o s e  o f  o t h e r s .   I f  y o u ’ r e  w o r k i n g  o n  t h e  l a b  o r  c l u s t e r  c o m p u t e r s ,  a r c h i v e  

y o u r  p r o j e c t ,  s a v e  i t  o n  y o u r  n e t w o r k  d r i v e ,  a n d  d e l e t e  i t  f r o m  t h e  l o c a l  h a r d  d r i v e .  I n  a d d i t i o n ,  g i v e  i t  a  u n i q u e  
n a m e ;  f o r  e x a m p l e , George W. Bush would name his Lab 3 “gwb_lab3” so it would not be confused with Tom 

Daschle’s Lab 3. 
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Geeky 
 

2 6 .  C h a n g e  t h e  o r i e n t a t i o n  o f  a  s y m b o l .   U s e  C t l - M  t o  m i r r o r ,  ( F i g u r e  2 5 )  C t l - L  t o  r o t a t e .  ( F i g u r e  2 6 )  

 

Figure 2 5  

 

 

Figure 2 6  

2 7 .  U s e  c o m p l e x  b u s e s  s e l e c t i v e l y  t o  m a k e  b u s e s  t h a t  a r e  c o n g l o m e r a t i o n s  o f  d i f f e r e n t  s i g n a l s .  

 

Figure 2 7  
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28. U s e  t h e  $ AR R AY  p a r a m e t e r  t o  c r e a t e  m u l t i p l e  i n s t a n c e s  o f  t h e  s a m e  c o m p o n e n t .  Al t h o u g h  t h i s  w o r k s ,  t h e  
d i s p l a y d o e s n ’t  n e c e s s a r i l y r e f l e c t  yo u r  c h a n g e s  ve r y a c c u r a t e l y. 

 

Figure 2 8  

 

Figure 2 9  
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2 9 .  Better yet, use the C ore G enerator to generate all kinds of components.  ( But remember that you hav e to make 

your components in L ab 3 .)   Be sure to set your D esign E ntry env ironment to “ S chematic- Foundation”  and your 

T arget A rchitecture to “ S partan2 .”   T he C ore G enerator can be v ery useful, but its uses are beyond the scope of 

this document.  Feel free to play around with it and see what it offers. 

 

Figure 30 
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30 . Find components fast by typing their name in the “SC Symbols” window. 

 

Figure 3 1  

31. The leftmost bit of a bus is the most significant, regardless of whether it is the highest bit or not.  Simplify your 

life by ordering buses consistently. 

32. Buses are connected to symbol pins in left-to-right order.  For example, in Figure 32, INT[15:8] is connected to 

FF2/D[7:0], whereas INT[7:0] is not connected to anything.  What a mess!  It’s best always to have the same 

number of bits on both sides. 

 

Figure 3 2  
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3 3 .  A v o i d  b u s  n a m e s  t h a t  e n d  w i t h  a  d i g i t .   F o r  e x a m p l e ,  i f  y o u  h a d  b u s e s  DATA1[10:0] and DATA[10:0], then 

DATA10 would exist twice. 

34. Use File->Table Setup to identify the schematic as yours.  (We don’t care whether you do this or not.) 

 

Figu r e  3 3  

35. Use the autoroute feature (Edit->Autorouting Table) if you think it’s worth it. 

36. If the simulator tells you that you have a “combinational feedback error,” this probably means that a net that is a 

function of an output of a combinational logic element feeds back into an input of the same element.  Look for 

naming errors.  In a few cases, the simulator has generated a combinational feedback error with no apparent 

reason, and students have solved the problem by replacing their logic with equivalent components. 

37 . U se the Project Libraries W indow (Tools->Project Libraries) and the Library Manager to manipulate 

the contents of your libraries.  EE121 students have not made much use of this facility. 

 

Figure 34 
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38 . Use the symbo l  edi to r  to  chan ge the symbo l s co r r espo n di n g to  yo u r  macr o s.  Ri ght-cl i ck  o n  the co mpo n en t an d 

cho o se “Symbo l  Edi to r .”  Y o u  can  do  al l  so r ts o f thi n gs,  l i k e mo ve pi n s ar o u n d,  mak e bu s I/O pi n s thi ck  ,  an d 

pl ace do ts o n  acti ve-l o w  pi n s. 

 

Figure 3 5  

39. I/O buffers and pads can go inside macros; they don’t have to be on the highest-level schematic.  (But they 

should be in Lab 3 because that’s the way the skeleton file is.) 

40 . I F D s and O F D s replace I B U F s and O B U F s.  You can register your inputs and outputs by replacing O B U F s and 
I B U F s with I F D s and O F D s. 


